
bonzai3d 3.0 is a major update to bonzai3d with over 80 new features including 14 new tools that 
add functionality for fabrication, 3D printing, NURBS modeling, shape editing, texture mapping and 
component management. The existing bonzai3d tools have been improved and tweaked to make them 
even more powerful and flexible. Similar improvements have been made throughout the interface 
such as the new Sun Position palette that makes creating shadow and sun studies a breeze. Extensive 
internal changes have improved the performance throughout bonzai3d making it even faster to 
produce great results.

The following is a summary of the changes found in bonzai3d 3.0. Following each summary is a link to the on 
line manual for bonzai3d 3.0 that contains all of the details of the particular feature. 

Please note that in order to make certain improvements, support for some older technology could no longer 
be maintained. OS X 10.6 is the now the minimum supported version for OS X and bonzai3d 3.0 no longer 
supports machines that use Power PC processors (G5, G4 etc). For windows users, Windows 8 is now 
supported

Interface changes:

The File Menu has new options. The Save All command saves all open bonzai3d files at the same time. The 
Project Info... menu entry has been relocated to the File Menu from the Help Menu.   Learn more... 

Printing has been improved. Vector Output is a new option in wireframe and hidden line display. With this 
option the line work and text are printed as resolution independent geometry to printers and PDF files.   Learn 
more... 

The Project Files tab of the Project Settings options has new options. These options may help to reduce the 
size for .fmz project files.   Learn more...

Keep Render Mesh: When selected the rendering mesh is saved in the project. The render mesh is 
needed for most rendering modes other than wireframe so if it is not saved in the project file, it will be 
recreated when needed and may have a noticeable performance impact.

Keep Textures: When selected, the texture maps used in the project are saved in the file. This makes 
the files portable as the textures are embedded in the file. When the option is off, the files will be smaller 
but the textures need to be re-loaded from their original location when the file is reopened. 

The Compression menu offers options to help mitigate the size of the textures embedded in the 
project. The Basic option uses deflate (zip) which is a lossless compression method. The JPEG option 
generates much smaller files, but at the expense of image quality (i.e. “lossy”).

Note that RenderZone will always load the original texture if the file is present for best results.
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The Preferences include revised methods for saving Preference files.   Learn more...

Icon Display: there are two slider controls here for changing the appearance of the icons throughout the 
interface.

Saturation: moving this slider will alter the how vivid the colors of the icons are. Moving it as far left as 
possible will make the icons appear in grayscale mode only. Moving it between far left and far right will 
create a mix of the full color icons and gray icons, muting the colors by the amount selected. 
 
Tint: This color box and slider can be used to assign a custom color that will be mixed with the icons, 
the Intensity slider controls the strength of this mixture. 

New icon display options in the Interface: Preferences

Rendering: Auto Save is a new feature and includes new methods for automatically saving image files. 
The format of the saved images and the destination can be specified.

Options for assigning File and Font search paths have been added, to allow for more flexibility.

Disable Scroll Wheel in Project Window: With this option on, the scroll wheel on a mouse will not cause the 
display to zoom in or out. 
 

New options in the Project files tab of the The Project Settings dialog.
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Use Tap Keys: This item controls the Tap key shortcuts. This item is on by default.

New Options in the Project: Modeling Preferences

The Edit Menu has two new options. Keep Tool Operands and Clear Ghosted Tool Operands control the 
status of objects for operations and allow clearing Ghosted operands created by tool operations only to be 
deleted. Objects ghosted with the Ghost tool will remain in the project.   Learn more...

The new Display Options palette.

Clicking on any 
of these icons 
changes the 

options below 
to those of that 
display type.

The Display Options for each display 
method has been revised, and new 
display features have been added, 
such as the option to show isolines, 
wire objects with silhuouette edges, 
anti-aliasing in wireframe display, and 
displaying components as bounding 
boxes or dashed boxes.   Learn more...

The Palettes menu has new names 
for two palettes. Bonzai3d Tools, and 
Component Manager replace the 
palette names for Modeling Tools and 
Components, respectively.   
Learn more...

The Show Axes and Show Face 
normals are now in the Tool Options 
palette of the pick tool and are per 
object, rather than affecting entire 
display modes.

Place Selected Objects On Layer and 
Select All Objects On Layer are new 
options in the Layers palette context 
menu.   Learn more... 

The Scenes and Views palettes now have back and forward arrows that allow for convenient cycling through 
the items in the list. You can quickly move from saved view to saved view, for example, without selecting each 
one individually from the list.  Animate Transitions is new in the Views palette context menu. This feature 
animates the view in the modeling window changing to the new view.   Learn more...
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The Sun Position palette allows interactive and accurate placement of the Sun in a project file. You can create 
accurate solar studies of your architectural projects and animate them in “fast motion”.   Learn more...  

A Sun Position simulation illustrating various times throught the day.

Quick Keys is a new palette that lists all of the “hidden” shortcuts. These are shortcuts that do not have tools 
or menu items that the user can set the shortcut from. This palette also contains the numeric parameters where 
applicable like the nudge distances etc. Learn more...
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Assign Picked Objects This Material is new in the Materials palette context menu.

The Help Menu has a new command.  The Getting Started... command invokes the introductory dialog that 
appears when first launching bonzai3d. This dialog provides links to the on-line Manual, bonzai3d videos, and 
Self-Paced Tutorials.   Learn more... 

The Getting Started dialog, which can be accessed from the Help menu.

Tool Options palette for Turntable

Licenses in Use... allows you to determine the number of bonzai3d licenses currently in use when used in a 
network configuration.

There is now an online Users Manual for bonzai3d 3.0. You can access the online documention if you have 
an internet connection. Choosing manual after invoking the context 
menu of any tool will open the documentation to the relevant passage. 
The RenderZone and Sketch Rendering manuals are also available 
from the Help menu, as well as from any tool or menu entry that are 
added by a plugin.   Learn more...

The Turntable tool is new in bonzai3d 3.0.  It will cause a scene to 
rotate continuously around an axis in realtime display modes.  There 
are controls for playing the animations, and adjusting the speed of the 
animation. This is a usful tool for presenting a 3d model in OpenGL 
mode.   Learn more...
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Edit Reference Plane has new options for orienting the reference 
plane, including Center On Scene, Center On Selection, Extents 
OF Scene, Extents Of Selection, Plane XY (a perpendicular plane), 
Plane XZ (a perpendicular plane at 90 degrees), and Align With 
View.    Learn more...

Stick To Edges is a new option in the Snap Options dialog. When 
this option is enabled, the snap point will stick to the nearest snap 
candidate point on the edge. That is the snapping will lock onto the 
nearest snap point of the edge, even if the cursor is not within the pixel 
tolerance of the point. This new option works with the Point, Interval, 
Intersection, Perpendicular or Tangent snap modes but not when 
Snap To Segment is enabled (as the point on the segment takes 
precedent).   Learn more...

Snap Options

Snapping with Stick to Edges Off Snapping with Stick to Edges On 

The context menu accessed by right-clicking on a component in the Component Palette has a new option 
Export All Components To Library.... This option functions as the option to export a single component, but 
exports all of the components in the palette. This makes it easier to export all the embedded components from 
a file.   Learn more...

Component instances now have their own override attributes. That is when an attribute like the material 
or shadow casting of a component is changed, it is applied to the placed instance and there is no prompt to 
update the component definition. This is works for all of the basic object attributes. Overridden attributes can 
be cleared when a component is selected with the Restore Original Attributes button in the Parameters 
tab of the Tool Options – Pick palette.  When an attribute is overridden, the override is indicated by a yellow 
exclamation mark to the right of the attribute in the Attributes table of the Tool Options – Pick palette. Note 
that objects affected by layer overrides have the same indicator.   Learn more...

Override icon showing a Material Override. The new Restore Original Attributes button in the 
Parameters tab of the Pick Tool Options.
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Tool changes:

The Pick tools have been revised.  The Pick Part tool has been removed, and all Picking operations are 
now completed with two Pick tools. The main Pick tool now allows picking parts through a Topological level 
selection that can be set as needed. The Pick tool also has an Auto-Pick topological level setting that 
automatically chooses the correct Topological level that is beneath the cursor when the cmd (OSX) or ctrl 
(Windows) key is depressed. Options for Allow Drag, Allow Copy, and Frame picking have been added to 
allow for more flexibility in Picking.   Learn more...

Shapes tool row with the new Arc 5 tool.

An Arc 5 tool has been added to the Shapes tool row. This tool creates an arc through three points on its 
circumference, the middle point being defined last.  Learn more...

The Pick Tool Options The Area Pick Tool Options

The Pick Tool row 
in bonzai3d 3.0, 

with the Pick Part 
tool removed.

Arc 5 

In addition to the new Arc 5 tool, arcs now have a Continuous option checkbox in the Tool Options palette so 
that multiple arcs that make up a single line entity can be drawn.

The Wire Helix tool has added an option for choosing between Facetted or Smooth results after the operation 
is complete.   Learn more...

Wire Helix
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The Billboard tool generates a special type of object that is a surface rectangle with an image (texture) 
mapped on it. It takes its dimensions from the size of the image.    Learn more...

The Billboard Tool options.Loading a Billboard Image and a Billboard in a project.

Billboard 

The Axial Sweep tool has a new icon, and the option to scale the source along the path is new.  Learn more... 

Axial Sweep

The Extrusion tools, 3D Extrusion, 3D Extrusion to Point have added the option to set a height value that 
will be used by the tool.  Learn more...

The 2D Surface tool has been replaced with the Derive Face tool, and a new tool for deriving segments, the 
Derive Segment tool, has been added.  Learn more...

Derive Tools

Extrusion Tools
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A Dynamic Section Example.
The Section Tool Options with a Dynamic 

Section Plane Active.

The 3D Wall tool has also had the height option added as per the Extrusion tools, in addtion to options for 
closing the top and bottom of 3D walls, they are used to create ceiling and floors.   Learn more...

The Unfold tool is a new tool which can be used to unfold objects, which can be surfaces or solids, in order to 
produce them as flat shapes that can be cut-out of stock and assembled.   Learn more...

The Section tool has a new option for dynamically sectioning. The dynamic operation allows the section plane 
to be adjusted as needed during the operation, while a direct section allows an arbitrary face or plane to be 
specified and the operation is excuted immediately.   Learn more...

3D Wall

Unfold Tool

Section

The Break line tool has a new option for specifying an opening be created at the break point.   Learn more...

The Break With Line tool is new and breaks an open or closed vector line or spline at the point where another 
line/spline intersects it.    Learn more... 

Break Line

Break With Line
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The Extend tool is new and extends an open line, spline, or arc.  Learn more... 

The new Extend to Line tool extends an open line, spline, or arc to its point of intersection with another line, 
spline, or arc.   Learn more...

The new Insert Segment tool allows you to draw a single segment line on a closed surface object or a face of 
a solid object, which it then inserts to the surface, causing the surface to be split in two.   Learn more...

The Mesh tool has new options for specifying the angle and placement of the mesh.  Learn more...

The new Remove Point tool will remove a point from an open or closed vector line shape.   Learn more... 

The Mirror tool has a new icon and new options for specifying the axis of the reflection.   Learn more...

Extend

Extend To

Insert Segment

Mesh

Remove Point

Mirror

The Measure Distance tool has a new options for resizing an object or underlay by specifying the new value 
for the currently measured entity or entities. The Reference Plane Underlay feature allows scaling of an 
Underlay by any two arbitrary points.   Learn more...

Measure Distance

The Paint tool has a new option for keeping the material of current faces.   Learn more...
Paint
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The Contour Doctor is a new tool in bonzai3d 3.0.  The Contour Doctor tool can be used to check the 
conditions of the contours, report problems, if any, and even correct their faults.   Learn more...

Contour Doctor

The Explode Component, Replace Component, and Make Individual Component are new. These tools 
simplfy managing components. The Component Manager has new options for exporting all embedded 
components to a new library, cancelling edits, and more.   Learn more...

Component Tools

The Linear Dimension, Angular Dimension, Radial/Diameter Dimension and Leader Line tools have 
revised icons. The Dimension tools and parameters have new interface buttons to quickly create new 
Dimension Styles or edit Dimension Style parameters. Dimensions, Leader Lines, and Notes now appear 
in the Hidden line rendering mode.   Learn more...

Dimension Tools

The C-Make tool has been replaced by the C-Create tool, and can generate NURBS curves.   Learn more...
Curve Create

The new Curve Convert tool converts a spline curve to a NURBS curve.   Learn more...

The C-Merge tool has options for controllng the merge extensions numerically.   Learn more...

Curve Convert

C-Merge 

The C-Extend tool has options for controllng the curve extensions numerically.   Learn more...

C-Extend

N-Loft

The N-Lofting tool has an option for adjusting the parametrization of a tight loft.   Learn more...
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NURBS Reconstruct Surface options.

NURBS Reconstruct Surface tool now functions in two 
distinctly different methods. When Keep Existing Control 
Points is selected, the control points are maintained and the 
shape of the surface is changed to match the desired degree 
(optionally keeping weights and knots as well).

When Approximate Original Surface is selected, the 
reconstructed surface matches the original surface as closely 
as possible using the specified parameters.   Learn more...

N-Reconstruct

N-Convert
Texture Map Options have been added to the NURBS Convert tool. When Clear to Default is selected, 
the resulting NURBS surface will use the default texture map control.  Otherwise, the NURBS surface will be 
assigned the texture map control of the original surface.   Learn more...

NURBS Blend tool has a new option. If the Auto-adjust Initial Seam and Orientation option is selected, 
when two surfaces closed in one direction are blended, the tool will find an initial seam adjustment and surface 
orientation that produces a good result.  The N-Blend tool has new options: Align Boundary Edges, Smooth, 
Adjust Seam, Update, and Auto-Update buttons.   Learn more...

N-Blend

N-Merge
The N-Merge tool has new options: Extend/Trim 1, Extend/Trim 2, and Close Loops.   Learn more...

N-Extend
The N-Extend tool has new options: Extend by Average Length. The surface will be extended based on the 
value entered.   Learn more...

A Perpendicular to Surface guide has been added when editing control points of NURBS surfaces. When 
clicking a control point to move it, a snap guide is shown that is perpendicular to the surface, through the 
control point. This allows the control point to be moved closer to, or further from, the surface. 
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DWG/DXF Component (Block) 
Import Options.

DWG Specific Export Options

Import/Export changes:

Modeling Import Options dialog has updated options for 
importing components (blocks). This includes the option to 
explode the components or to embed them in the project.
Learn more...

Art•lantis import and export has been updated to include 
Art*lantis 4.5.  

DXF and DWG export options has a new option to Include 
Lights in the exported file. This option is off by default as 
lights are not usefull to many CAD applications that read DXF/
DWG files.   Learn more...

The Latitiude and Longitude entry for exporitng to KMZ 
was revised for bonzai3d 3.0, and allows more accurate 
placement in Google Earth.   Learn more...

OBJ Import options has a new option to Invert 
Transparency in the imported materials. The use of 
transparency values in the obj files is not consistent. If you 
encounter a file where opaque materials appear transparent 
when imported, use this option to correct the problem.  

3D Print Prep

The 3D Print Preparation tool is new in bonzai3d 3.0.  The tool will diagnose common problems with objects 
when exporting for 3D printing.   Learn more...
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